<!DOCTYPE html>
<!--[if IEMobile 7]><html class="iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product#"><!--<![endif]-->

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <!--[if IE]><![endif]-->
<meta charset="utf-8" />
<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@graph": [
        {
            "@type": "ReportageNewsArticle",
            "headline": "SteelSeries\u2019 Arctis 1 is a headset for budget-conscious gamers",
            "description": "Cheap thrills",
            "author": {
                "@type": "Person",
                "name": "Matt Tate",
                "url": "https://www.stuff.tv/team/matt-tate"
            },
            "publisher": {
                "@type": "NewsMediaOrganization",
                "name": "Kelsey Media Ltd",
                "url": "https://www.kelsey.co.uk/",
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://images.cdn.stuff.tv/sites/stuff.tv/files/copyright_0.png",
                    "width": "81",
                    "height": "20"
                }
            },
            "datePublished": "2019-06-11T16:09:01+0100",
            "dateModified": "2019-06-11T16:09:01+0100",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.stuff.tv/sites/stuff.tv/files/brands/Steelseries/arctissteelseries1hs.jpg",
                "width": "770",
                "height": "578"
            },
            "mainEntityOfPage": "https://www.stuff.tv/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers",
            "about": [
                "Games consoles",
                "Arctis 1"
            ]
        },
        {
            "logo": {
                "@type": "ImageObject",
                "url": "https://shop.kelsey.co.uk/images/kp-logo.png",
                "width": "150",
                "height": "225"
            },
            "@type": "NewsMediaOrganization",
            "name": "Kelsey Media Ltd",
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "Cudham Tithe Barn",
                "addressLocality": "Berry\u0027s Hill",
                "addressRegion": "Cudham",
                "postalCode": "TN16 3AG",
                "addressCountry": "GB"
            },
            "url": "https://www.kelsey.co.uk/",
            "sameAs": [
                "https://twitter.com/kelseygroup",
                "https://www.linkedin.com/company/kelsey-publishing-ltd/"
            ],
            "publishingPrinciples": "https://www.stuff.tv/about-trust-project",
            "foundingDate": "1989-07-01",
            "ethicsPolicy": "https://www.stuff.tv/about-trust-project#one",
            "diversityPolicy": "https://www.stuff.tv/about-trust-project#two",
            "diversityStaffingReport": "",
            "correctionsPolicy": "https://www.stuff.tv/about-trust-project#three",
            "ownershipFundingInfo": "https://www.stuff.tv/about-trust-project#four",
            "masthead": "https://www.stuff.tv/about-us",
            "missionCoveragePrioritiesPolicy": "https://www.stuff.tv/about-trust-project#five",
            "verificationFactCheckingPolicy": "https://www.stuff.tv/about-trust-project#six",
            "unnamedSourcesPolicy": "",
            "contactPoint": [
                {
                    "@type": "ContactPoint",
                    "contactType": "Newsroom contact",
                    "email": "reception@kelsey.co.uk",
                    "telephone": "01959 541444",
                    "url": "https://www.stuff.tv/contact-us"
                }
            ]
        },
        {
            "@type": "WebSite",
            "name": "Stuff",
            "url": "https://www.stuff.tv/",
            "sameAs": [
                "https://www.facebook.com/joinstuff",
                "https://twitter.com/Stufftv",
                "https://plus.google.com/+StuffTV",
                "https://www.youtube.com/user/stuffmagazine"
            ]
        }
    ]
}</script>
<link rel="shortcut icon" href="https://www.stuff.tv/sites/stuff.tv/files/stuff_favicon_0.ico" type="image/vnd.microsoft.icon" />
<link href="https://www.stuff.tv/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers?_format=amp" rel="amphtml" />
<meta name="description" content="Cheap thrills" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.stuff.tv/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers" />
<link rel="shortlink" href="https://www.stuff.tv/node/100005066" />
<meta property="og:site_name" content="Stuff" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.stuff.tv/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers" />
<meta property="og:title" content="SteelSeries’ Arctis 1 is a headset for budget-conscious gamers" />
<meta property="og:description" content="Cheap thrills" />
<meta property="og:image" content="https://www.stuff.tv/sites/stuff.tv/files/brands/Steelseries/arctissteelseries1hs.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@stufftv" />
<meta name="twitter:url" content="https://www.stuff.tv/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers" />
<meta name="twitter:description" content="Cheap thrills" />
<meta name="twitter:title" content="SteelSeries’ Arctis 1 is a headset for budget-conscious gamers" />
<meta name="twitter:image" content="https://www.stuff.tv/sites/stuff.tv/files/brands/Steelseries/arctissteelseries1hs.jpg" />
  <title>SteelSeries’ Arctis 1 is a headset for budget-conscious gamers | Stuff</title>
      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="/sites/stuff.tv/files/advagg_css/css__YZMmyCjxADNsxWJVyzxskiYBiPsGboww8DDJoAv1iVA__PqGVjSeXe3e-YM4xspxCavDlyydtEB28TRpZPTEwV5I__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/stuff.tv/files/advagg_css/css__BF8W_blKQtPnbjQTY9x1jeMYAPMgw_DaHD_Jx-1OrhE__VgwyfQt-yRZrTCQFX_pOadE6PR9mZKmik_FgvfGFGJc__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.css" media="screen" />
<link type="text/css" rel="stylesheet" href="/sites/stuff.tv/files/advagg_css/css__jjEdIwINPRs5BCpSK59_JjLiKBCs__QLmL3t8MvHU1k__3PWeSxBEp25JZfdB0q4a1THV5KGElJ3sZQngWGz2xDM__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/stuff.tv/files/advagg_css/css__iYREzXqa58qHdZO5iD-vQRM8RqqvmMt7dUSrT4IULNM__JYW5hsA6Qq3Y12AM10C3-8TDnyLKGTiOMq5iY-0sBOw__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/stuff.tv/files/advagg_css/css__F4DGzaQ3JMSywZYTdHQqhVqJ_IKuCHvsD2vZtn-vC8I__mw3G8NGXabG0e3sRuhZY09x1g7fj37wx1Yqf-lSEJg0__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.css" media="all" />
<style>#sliding-popup.sliding-popup-top,#sliding-popup.sliding-popup-top .eu-cookie-withdraw-banner,.eu-cookie-withdraw-tab{background:#5c5c5c;}#sliding-popup.sliding-popup-top.eu-cookie-withdraw-wrapper{background:transparent}#sliding-popup .popup-content #popup-text h1,#sliding-popup .popup-content #popup-text h2,#sliding-popup .popup-content #popup-text h3,#sliding-popup .popup-content #popup-text p,.eu-cookie-compliance-more-button,.eu-cookie-compliance-secondary-button,.eu-cookie-withdraw-tab{color:#ffffff !important;}.eu-cookie-withdraw-tab{border-color:#ffffff;}
</style>
<link type="text/css" rel="stylesheet" href="/sites/stuff.tv/files/advagg_css/css__mM9LgvGvph8F-SPcvF7i_nd84MSS5eU_cf01_3x_Uj4__i4Yg9siRXCA-07ocxNFvOclhiBZq9BM_kJAQsRX8F0g__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.css" media="all" />

      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-100005066 node-type-article i18n-en section-hot-stuff hot-stuff byline-available" >
    <div class="region region-page-top">
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WR42SKR" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>  </div>
   
<div id="page">

  <header id="header" role="banner" class="clearfix">
    <div class="grey">
      <div class="container">
        <div class="grid_16">
            <div class="region region-hat">
    <div id="block-lang-dropdown-language" class="block block-lang-dropdown first odd">

        <h2 class="block__title block-title">Languages</h2>
    
  <form action="/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers" method="post" id="lang-dropdown-form" accept-charset="UTF-8"><div><div class="form-item form-type-select form-item-lang-dropdown-select">
 <select style="width:140px" class="lang-dropdown-select-element form-select" id="edit-lang-dropdown-select" name="lang_dropdown_select"><option value="en" selected="selected">&lt;span&gt;Stuff UK&lt;/span&gt;
</option><option value="fr-FR">&lt;span&gt;Stuff France&lt;/span&gt;
</option><option value="en-IN">&lt;span&gt;Stuff India&lt;/span&gt;
</option><option value="en-MY">&lt;span&gt;Stuff Malaysia&lt;/span&gt;
</option><option value="en-ME">&lt;span&gt;Stuff Middle East&lt;/span&gt;
</option><option value="en-ZA">&lt;span&gt;Stuff South Africa&lt;/span&gt;
</option></select>
</div>
<input type="hidden" name="lang_dropdown_type" value="language" />
<input type="hidden" name="en" value="/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers" />
<input type="hidden" name="fr-FR" value="/fr" />
<input type="hidden" name="en-IN" value="/in" />
<input type="hidden" name="en-MY" value="/my" />
<input type="hidden" name="en-ME" value="/me" />
<input type="hidden" name="en-SG" value="/sg" />
<input type="hidden" name="en-ZA" value="/za" />
<noscript><div>
<input type="submit" id="edit-submit" name="op" value="Go" class="form-submit" />
</div></noscript><input type="hidden" name="form_build_id" value="form-JQA1qman06xF8BchdwyJmWI8c4ys6rdaS1peUN9-ftk" />
<input type="hidden" name="form_id" value="lang_dropdown_form" />
</div></form>
</div>
<div id="block-buy-magazine-buy-magazine-short" class="block block-buy-magazine even">

      
  <a href="https://shop.kelsey.co.uk/subscription/STU" class="themag" target="_blank">Subscribe to the magazine</a>
</div>
<div id="block-stuff-login-extras-stuff-login-extras-block" class="block block-stuff-login-extras odd">

      
  <div class="item-list"><ul class="ajax-register-links inline"><li class="first last"><a href="/ajax_register/login/nojs" class="ctools-use-modal ctools-modal-ctools-ajax-register-style" rel="nofollow" title="Login">Login</a></li>
</ul></div>
</div>
<div id="block-menu-menu-social-icons" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Follow us</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/joinstuff" title="Follow Stuff on Facebook" class="menu__link menu_icon menu-163">Stuff on Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/Stufftv" title="Follow Stuff on Twitter" class="menu__link menu_icon menu-164">Stuff on Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/+StuffTV" title="Follow Stuff on Google Plus" rel="publisher" class="menu__link menu_icon menu-165">Stuff on Google</a></li>
<li class="menu__item is-leaf last leaf"><a href="https://www.youtube.com/user/stuffmagazine" title="Subscribe to Stuff&#039;s YouTube channel" class="menu__link menu_icon menu-615">Stuff on YouTube</a></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>
    <div class="red">
      <div class="container">
        <div class="grid_16 top-header-grid clearfix">
                      <a href="/" class="logo-retina" title="Home" rel="home" id="logo_retina"><img src="/sites/stuff.tv/themes/stuff/logo_retina.png" alt="Home" /></a>
            <a href="/" class="logo-standard" title="Home" rel="home" id="logo"><img src="/sites/stuff.tv/themes/stuff/logo.png" alt="Home" /></a>
                    <div id="mobile-search-trigger"></div>
          <div id="mobile-menu-trigger">Menu</div>
        </div>
      </div>
    </div>
    <div class="over">
      <div class="container">
        <div class="grid_16">
            <div class="region region-header-top">
    <div id="block-search-form" class="block block-search first last odd" role="search">

      
  <form action="/hot-stuff/gaming/steelseries-arctis-1-headset-budget-conscious-gamers" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." class="auto_submit form-text form-autocomplete" placeholder="Enter your keywords here" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" /><input type="hidden" id="edit-search-block-form--2-autocomplete" value="https://www.stuff.tv/index.php?q=admin/search/autocomplete" disabled="disabled" class="autocomplete" />
</div>
<input type="hidden" name="form_build_id" value="form-YFsElgF1Mauuu3-t6u8xrI3yd-4qj1a-slBwv8CLF9Q" />
<input type="hidden" name="form_id" value="search_block_form" />
<input type="hidden" name="typed" value="" />
<input type="hidden" name="pos" value="top" />
<input type="hidden" name="source" value="textfield" />
</div>
</div></form>
</div>
  </div>
                      <nav id="main-menu" role="navigation" class="clearfix">
              <ul class="menu"><li class="menu__item is-leaf first leaf hot-stuff-menu-link"><a href="/hot-stuff" class="menu__link">Hot Stuff</a></li>
<li class="menu__item is-leaf leaf news-menu-link"><a href="/news" class="menu__link block-menu">News</a></li>
<li class="menu__item is-leaf leaf reviews-menu-link"><a href="/reviews" class="menu__link block-menu">Reviews</a></li>
<li class="menu__item is-leaf leaf features-menu-link"><a href="/features" class="menu__link">Features</a></li>
<li class="menu__item is-leaf leaf top-10s-menu-link"><a href="/top-10" class="menu__link no-transform">TOP 10s</a></li>
<li class="menu__item is-leaf leaf deals-menu-link"><a href="/deals/best-stuff-deals" class="menu__link">Deals</a></li>
<li class="menu__item is-leaf last leaf win-menu-link"><a href="/win" class="menu__link">WIN</a></li>
</ul>            </nav>
                    <div class="desktop-search"></div>
        </div>
      </div>
    </div>
    <div class="container">
      <div class="grid_16">
              </div>
    </div>
  </header>

  <div class="fake-body">
          <div id="leaderboard" class="container">
          <div class="region region-leaderboard">
    <div id="block-hcm-external-blocks-leaderboard-all" class="block block-hcm-external-blocks first last odd">

      
  <div id="gpt_7294_leaderboard_all"></div>
</div>
  </div>
      </div>
        <div id="trending" class="container hot-stuff"><div class="grid_16 trending hot-stuff">  <div class="region region-trending">
    <div id="block-views-taxonomies-block-1" class="block block-views first last odd">

      
  <div class="container">
  <div class="view view-taxonomies view-id-taxonomies view-display-id-block_1 view-dom-id-184b0368412b8e26ec08347dd9030d90">
                
    
          <div class="attachment attachment-before">
        <a href="#" class="hot-stuff-filter-toggle">Filter</a>
        <div class="view view-taxonomies view-id-taxonomies view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-sponsor-logo">        <div class="field-content"><a href="/hot-stuff"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source data-srcset="https://www.stuff.tv/sites/stuff.tv/files/styles/logo/public/HotStuffLogo.png?itok=IysTj1XG&amp;timestamp=1509795181 1.5x, https://www.stuff.tv/sites/stuff.tv/files/styles/logo-small/public/HotStuffLogo.png?itok=zQ1AF_wS&amp;timestamp=1509795181 1x, https://www.stuff.tv/sites/stuff.tv/files/styles/logo/public/HotStuffLogo.png?itok=IysTj1XG&amp;timestamp=1509795181 2x" data-aspectratio="395/50" />
<!--[if IE 9]></video><![endif]-->
<img  class="lazyload" data-aspectratio="" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="" title="" />
</picture></a></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>      </div>
    
          <div class="view-content">
          <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/apps">Apps</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/audio">Audio</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/cameras">Cameras</a></span>  </div>  </div>
  <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/cars-bikes">Cars &amp; bikes</a></span>  </div>  </div>
  <div class="views-row views-row-5 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/gaming">Gaming</a></span>  </div>  </div>
  <div class="views-row views-row-6 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/gear">Gear</a></span>  </div>  </div>
  <div class="views-row views-row-7 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/promoted">Promoted</a></span>  </div>  </div>
  <div class="views-row views-row-8 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/smart-home">Smart home</a></span>  </div>  </div>
  <div class="views-row views-row-9 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/smartphones">Smartphones</a></span>  </div>  </div>
  <div class="views-row views-row-10 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/tablets-computers">Tablets &amp; computers</a></span>  </div>  </div>
  <div class="views-row views-row-11 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/tech-toys">Tech toys</a></span>  </div>  </div>
  <div class="views-row views-row-12 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/tvs">TVs</a></span>  </div>  </div>
  <div class="views-row views-row-13 views-row-odd views-row-last">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/wearables">Wearables</a></span>  </div>  </div>
      </div>
    
    
    
    
    
    
  </div></div>

</div>
  </div>
</div></div>        <div id="main" class="container clearfix"  >
                                                <div id="content" class="column grid_16 clearfix" role="main">

        
                <a cid="main-content"></a>
                        
                                                <div id="content-top">
                  </div>
        




<article class="node-100005066 node node-article view-mode-hot_stuff_content clearfix hot-stuff-content">
    <header>
              <div class="main-image">
          <div class="field field-name-field-image field-type-image field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=-RNoAlCN&amp;timestamp=1560265507 1.5x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=ugaJAT8k&amp;timestamp=1560265507 1x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=-RNoAlCN&amp;timestamp=1560265507 2x" media="only screen and (max-width : 480px)" />
<source srcset="https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=XdR1lTbT&amp;timestamp=1560265507 1.5x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=kS1FwMiS&amp;timestamp=1560265507 1x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=XdR1lTbT&amp;timestamp=1560265507 2x" media="only screen and (max-width : 767px)" />
<source srcset="https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=-RNoAlCN&amp;timestamp=1560265507 1.5x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=ugaJAT8k&amp;timestamp=1560265507 1x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=-RNoAlCN&amp;timestamp=1560265507 2x" media="only screen and (max-width : 1023px)" />
<source srcset="https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=XdR1lTbT&amp;timestamp=1560265507 1.5x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=kS1FwMiS&amp;timestamp=1560265507 1x, https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=XdR1lTbT&amp;timestamp=1560265507 2x" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://www.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/arctissteelseries1hs.jpg?itok=XdR1lTbT&amp;timestamp=1560265507" alt="" title="" />
</picture></div>
      </div>
</div>
        </div>
      
            

      <div class="trust-project-indicator--type-of-work">News</div>

                    <h1 class="node__title node-title">SteelSeries’ Arctis 1 is a headset for budget-conscious gamers</h1>
      
            
        
                  <div class="standfirst"><div class="field field-name-field-standfirst field-type-text-long field-label-hidden">
    <div class="field-items">
          <div class="field-item even">Cheap thrills</div>
      </div>
</div>
</div>
        
                        <div class="tags">
            <div class="category">
              <!-- <a href="<a href="/taxonomy/term/13826" class="label_category">Gaming</a>"/><a href="/taxonomy/term/13826" class="label_category">Gaming</a></a> -->
              <a href="/taxonomy/term/13826" class="label_category">Gaming</a>            </div>
                          <div class="sub-category">
                       </div>
        </div>
        
                  <div class="authorship clearfix">
            <!-- Hiding time from page 2 onwards. -->

                          <div class="field field-name-field-byline field-type-entityreference field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><div class="article-byline">
      <div class="field field-name-field-image field-type-image field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><a href="/team/matt-tate"><img src="https://www.stuff.tv/sites/stuff.tv/files/styles/thumbnail/public/moi.jpg?itok=f73w5s76" width="100" height="75" alt="" /></a></div>
      </div>
</div>
    <div class="byline-content">
    <div class="author">
    	<span>by&nbsp;</span><a itemprop="author" itemscope itemtype="http://schema.org/Person" rel="author" href="/team/matt-tate"><span itemprop="name"> Matt Tate</span></a>
    </div>
    <div class="follow-button">
      <div class="field field-name-field-twitter field-type-text field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><a href="https://twitter.com/MattWTate" class="twitter-follow-button" data-show-count="false" data-lang="en">Follow @MattWTate</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.async=true,js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
      </div>
</div>
    </div>
  </div>
</div>
</div>
      </div>
</div>
                                      <div class="separator">|</div>
              <div class="ago">
  <i class="fa fa-clock-o" aria-hidden="true"></i>
  2 hours ago</div>
                      </div>
                  </header>
  
  <div class="amp-content">
    <div class="field field-name-body field-type-text-with-summary field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><div><p>SteelSeries is always a good bet for a well-made gaming headsets, and its latest puts a lot of the good bits of more expensive models into a entry-level pair of cans. The £50 Arctis 1 features the same speaker drivers, soundscape and noise-cancelling ClearCast mic as the Arctis 3, 5, 7 and 9X, but the latter is now detachable (rather than retractable) if you have no desire to talk to 17-year-olds from Leeds who are beating you at FIFA. The Arctis 1 also trades the ski goggle suspension headband for a design better suited to on-the-go use, and its 3.5mm connection means it can be used with the PS4, Xbox One, Nintendo Switch and PC. It’s available to buy right now.</p></div></div>
      </div>
</div>
<div class="field field-name-field-label field-type-taxonomy-term-reference field-label-hidden">
    <div class="field-items">
          <div class="field-item even">Gaming</div>
      </div>
</div>
  </div>
</article>
          <div class="region region-content-bottom">
    <div id="block-digiteka-digiteka" class="block block-digiteka first last odd">

      
  <div id="ultimedia_wrapper"></div>
      <script type="text/javascript">
        var ULTIMEDIA_mdtk = "02564791";  
        var ULTIMEDIA_zone= "2";
        var ULTIMEDIA_target = "ultimedia_wrapper";
        var ULTIMEDIA_async = true;                                                                                                    
      </script>
</div>
  </div>
      </div><!-- /#content -->

      
    </div><!-- /#main -->
  </div>

  <div class="container">
    <div class="grid_16">
          </div>
  </div>

        <div id="footer-links">
      <div class="container">
        <div class="grid_16">
            <div class="region region-footer-links-left">
    <div id="block-stuff-login-extras-stuff-login-extras-block--2" class="block block-stuff-login-extras first odd">

      
  <div class="item-list"><ul class="ajax-register-links inline"><li class="first last"><a href="/ajax_register/login/nojs" class="ctools-use-modal ctools-modal-ctools-ajax-register-style" rel="nofollow" title="Login">Login</a></li>
</ul></div>
</div>
<div id="block-menu-menu-footer-left-links" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer - Left links</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/about-us" class="menu__link">About Stuff  /</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact-us" class="menu__link">/ Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.kelsey.co.uk/terms/" class="menu__link">Terms &amp; Conditions /</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.kelsey.co.uk/privacy-policy/" target="_blank" class="menu__link">/ Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/advertise" class="menu__link">Advertise</a></li>
<li class="menu__item is-leaf last leaf"><a href="/sponsored-and-promoted-content" class="menu__link">Sponsored/Promoted Content</a></li>
</ul>
</div>
  </div>
            <div class="region region-footer-links">
    <div id="block-menu-menu-social-icons-bottom" class="block block-menu first odd" role="navigation">

        <h2 class="block__title block-title">Follow us</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/joinstuff" class="menu__link menu_icon menu-1630" target="_blank">Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/Stufftv" class="menu__link menu_icon menu-1631" target="_blank">Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/+StuffTV" rel="publisher" class="menu__link menu_icon menu-1632" target="_blank">G Plus</a></li>
<li class="menu__item is-leaf last leaf"><a href="https://www.youtube.com/user/stuffmagazine" class="menu__link menu_icon menu-1633" target="_blank">YouTube</a></li>
</ul>
</div>
<div id="block-buy-magazine-buy-magazine" class="block block-buy-magazine last even">

        <h2 class="block__title block-title">Subscribe to the magazine</h2>
    
    <div id="buy_magazine_print" class="clearfix">
    <div class="main_image small-4 columns">
        <a href="https://shop.kelsey.co.uk/subscription/STU"><img src="https://www.stuff.tv/sites/stuff.tv/files/styles/buy_magazine_print/public/stuff_sep_188.jpg?itok=20Pw53qf" width="360" height="480" alt="" /></a>    </div>
    <div class="content small-8 columns">
        <a href="https://shop.kelsey.co.uk/subscription/STU" class="arrow">Subscribe now</a>                  </div>
  </div>

</div>
  </div>
        </div>
      </div>
    </div>
        <div id="footer-wrapper">
      <div class="container">
        <div class="grid_16">
            <footer id="footer" class="region region-footer">
    <div id="block-copyright-notice-copyright-notice" class="block block-copyright-notice first last odd">

      
  <a href="/kelsey.co.uk"></a><div class="copyright-notice-text">&copy; KELSEY Media Ltd, Cudham Tithe Barn, Berry’s Hill, Cudham, Kent TN16 3AG, England. Registered in England. All rights reserved.</div>
</div>
  </footer>
        </div>
      </div>
    </div>
  </div><!-- /#page -->

  <div class="region region-bottom">
    <div id="block-block-2" class="block block-block first odd">

      
  <script>
<!--//--><![CDATA[// ><!--

var unruly = window.unruly || {};
unruly.native = unruly.native || {};
unruly.native.siteId =1101189;

//--><!]]>
</script><script src="//video.unrulymedia.com/native/native-loader.js"></script>
</div>
<div id="block-block-1" class="block block-block even">

      
  <script src="//biddr.brealtime.com/46414438-1239.js" type="text/javascript"></script>
</div>
<div id="block-block-3" class="block block-block last odd">

      
  <script type="text/javascript" src="https://cdn.connectignite.com/srv/inimage/16345/add.js" id="cibn-ads"></script>
</div>
  </div>
  <script src="/sites/stuff.tv/files/advagg_js/js__sZ-WmG60vc5651fbDLpJkNtOW2xV14GShR3eQtgcPuY__tgOb2Vb8IYhfTpuo6pUZG5jASQ-OD-ov73YbzkkHumY__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script src="/sites/all/libraries/modernizr/modernizr.custom.84112.js?psy3hd"></script>
<script>(function(h,o,t,j,a,r){
  h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
  h._hjSettings={hjid:"95165",hjsv:5};
  a=o.getElementsByTagName('head')[0];
  r=o.createElement('script');r.async=1;
  r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
  a.appendChild(r);
})(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');</script>
<script src="/sites/stuff.tv/files/advagg_js/js__nBqmjfnmFfknzXjo37NH58CiS9lfbbhkXtUQYxl8_2s__jyJNVAp7jVu4eGh-XYySY4XWsA2lkwF_hVKBfxT6a9w__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script>
      Drupal.hcmExternalBlocks = {}; 
      Drupal.hcmExternalBlocks.availableSlots = [];</script>
<script>var ppos = "stuff nodes"; var pageDnaObj = {"content":{"authors":"","has_video":"false","has_gallery":"false","has_poll":"","id":"100005066","language":"en","page_of":"","rating_max":"5","rating_score":"","title":"SteelSeriesArctis1isaheadsetforbudgetconsciousgamers","type":"Gaming","landing":"","subtype":"","publish_date":"20190611","update_date":"20190611","publish_time":"1609","update_time":"1609","taxonomy_group1":"","taxonomy_group2":"","taxonomy_group3":"","taxonomy_group4":"","freetags":"","word_count":"116","pagetype":""},"navigation":{"locale":"enGB","site_domain":"www.stuff.tv","site_name":"stuff.uk","section_child1":"stuff.uk","section_child2":"HotStuff","section_child3":"Gaming","section_child4":"none","section_child5":"Steelseries"},"search":{"searchphrase":""},"product":{"id":"","manufacturer":["Steelseries"],"model":["Arctis1"],"category":["Gaminghardware"],"sub_category1":["Gamesconsoles"],"product_edition":"","style":"","size":"","condition":"","price":"","price_band":"","target_price":"","price_currency":"","offer_price":"","min_price":"","max_price":"","version":"","colour":"","dealer":"","dealer_id":"","dealer_group":"","features":"","location":"","green_band":""},"electronics":[],"adzone":{"2":"HotStuff","3":"Gaming","4":"none","5":"Steelseries"}}</script>
<script>Drupal.hcmExternalBlocks.availableSlots.push("gpt_7294_leaderboard_all");</script>
<script src="/sites/stuff.tv/files/advagg_js/js__3LuYkqUjZCBoSLlHr2m61kSbmsCSqUKFXy8HcWtx3W4__fjMmdyFoQfs65a7ohq9q0rrTzQSedREzEOJ7PEgkNE8__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js" async="async"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__RPyYfJ4hDepGgZWtp1VbdI9yRaaKhnupkp97kCqBx00___VKZphQ1g0R1q7NLg3c5j8TW51VAlZJ6OKVG4z51ylM__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__jq17M-Yn_NCLn9fAP1e9VYcwYPzfnHMvZJeRHnXxzb0__Eb6lKcH_m17idr7gsrEY7-M8ZzzuhGRfALj8WgvtM9k__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js" async="async"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__R-RfRnvIE-uJ59vXo3U7qcBVvEATILP14NWFKcKdhW8__1QUt1wio2GqjYym6YnEMeKdOPTK3FbTE0L46vYoeGvk__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__T-zwXQR1TjycvjEDKwQ2ikF_wWI8uoD_aKRNXqc_f5A__finR7UoRF47hSrnfCydogjJ1iMMVFdSAyMgCBq427V4__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script async="async" src="https://js-sec.indexww.com/ht/p/185499-201610479662419.js"></script>
<script src="https://c.amazon-adsystem.com/aax2/amzn_ads.js"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__pPXUWpLn9m5pER4PMdbQy3De5weVwihmO58du20e_wg__u1QODEfwVkxWVITeGT8b0_YRga00gVPfPTAyNiDr5WY__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script>document.createElement( "picture" );</script>
<script async="async" src="https://sadmin.brightcove.com/js/BrightcoveExperiences.js"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__Q7U5vUwo8vWgaK1ZSdeXaCvPQ2D-VdMrJR_DKh4X8hU__F3PZOfkuPNs5QJriiDq08lH854TXFK1eK5f52rP3TCc__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-2421433-101", {"cookieDomain":"stuff.tv","allowLinker":true});ga("require", "displayfeatures");ga("require", "linker");ga("linker:autoLink", ["stuff.tv","www.stuff.tv","staging-drupal7-stuff-tv.platform.stuff.tv"]);var map = {
  contentGroup1: 'DNA_product_manufacturer',
  contentGroup2: 'DNA_product_model',
  contentGroup3: 'DNA_content_authors',
  contentGroup4: 'DNA_product_category',
  contentGroup5: 'DNA_content_type',

  dimension1  : 'DNA_content_publish_date',
  dimension2  : 'DNA_content_publish_time',
  dimension3  : 'DNA_content_update_date',
  dimension4  : 'DNA_content_update_time',
  dimension5  : 'DNA_content_authors',
  dimension6  : 'DNA_content_type',
  dimension7  : 'DNA_content_subtype',
  dimension8  : 'DNA_product_manufacturer',
  dimension9  : 'DNA_product_model',
  dimension10 : 'DNA_product_category',
  dimension11 : 'GA_adzones',
  dimension12 : 'DNA_content_id',
  dimension13 : '',
  dimension14 : '',
  dimension15 : '',
  dimension16 : '',
  dimension17 : '',
  dimension18 : 'DNA_content_has_video',
  dimension19 : 'DNA_content_taxonomy_group1'
};

for (var key in map) {
  var dnaKey = map[key], dnaVal = b[dnaKey];
  if (dnaVal !== undefined && dnaVal.length) {
    ga("set", key, dnaVal.toString());
  }
}


ga("set", "dimension20", jQuery('#retail_price > div.price-field > div > div > div').text());ga("send", "pageview");</script>
<script src="/sites/stuff.tv/files/advagg_js/js__3ZTWOa2m_7Km0KP2Ya9lCNQ24qnyvHgyNUN-DCv4uJE__9vIPztHLx-lk0KAcz4tA7z2mqNIvqMU3XweaXsKditI__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script async="async" src="https://www.ultimedia.com/js/common/smart.js"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__R0yPNWiX2E5GUK4TUsZjjJc8XDktriqhqP2Ib1WBTZA__jjaTihC_rzj0J9LbYBL9woWQ38t3aaLkTPUtTmXW_kI__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__BTeIQCJEmJs3T9llW6TxlMTNec5f1ExLAaAzJKU1vM0__50cXHnjPQsqWCaW8_36xyJRF5ha9EVqdNTmqF2BSFuA__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
<script>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</script>
  <script src="/sites/stuff.tv/files/advagg_js/js__GM3GJPR36rRIz0TRkjC5OQwrioSyN9aoYRivDhCO_AM__qAl84FcCv2jyN22yFGS5Oc85cjd9zKX6p_cFNLGhe-M__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js" async="async"></script>
<script>function euCookieComplianceLoadScripts() {}</script>
<script>var eu_cookie_compliance_cookie_name = "";</script>
<script>var skimlinks_domain = "go.redirectingat.com";</script>
<script async="async" src="https://s.skimresources.com/js/1044x507144.skimlinks.js"></script>
<script src="/sites/stuff.tv/files/advagg_js/js__WcTpt-w0y1FyXrxZNriX8Ts1KjsFTDpdvZaw9yhRn24__Zz3Wr35U3o6XmTnZsnxUaeuftbjlMppkPkYNH9P-hNA__Vhrj1qfXFwQ0Zo3XI_GghgUONjMRJ3t46abAE7lh1aE.js"></script>
</body>
</html>
