<!DOCTYPE html>
<!--[if IEMobile 7]><html class="iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product#"><!--<![endif]-->

<head profile="http://www.w3.org/1999/xhtml/vocab">
  <!--[if IE]><![endif]-->
<meta charset="utf-8" />
<meta http-equiv="x-dns-prefetch-control" content="on" />
<link rel="dns-prefetch" href="//images.cdn.stuff.tv" />
<link rel="dns-prefetch" href="//css.cdn.stuff.tv" />
<link rel="dns-prefetch" href="//cdn.stuff.tv" />
<!--[if IE 9]>
<link rel="prefetch" href="//images.cdn.stuff.tv" />
<link rel="prefetch" href="//css.cdn.stuff.tv" />
<link rel="prefetch" href="//cdn.stuff.tv" />
<![endif]-->
<link rel="shortcut icon" href="https://cdn.stuff.tv/sites/stuff.tv/files/stuff_favicon_0.ico" type="image/vnd.microsoft.icon" />
<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@graph": [
        {
            "author": {
                "@type": "Person",
                "name": "Tom Morgan",
                "url": "https://www.stuff.tv/team/tom-morgan"
            },
            "@type": "ReportageNewsArticle",
            "headline": "Gaming headphones go Hi-Res with the Steelseries Arctis Pro",
            "description": "Uprated speakers and a dedicated DAC make this the headset for serious sound fans",
            "publisher": {
                "@type": "NewsMediaOrganization",
                "name": "Haymarket media group",
                "url": "http://www.haymarket.com/",
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://images.cdn.stuff.tv/sites/stuff.tv/files/copyright_0.png",
                    "width": "81",
                    "height": "20"
                }
            },
            "datePublished": "2018-03-12T23:01:00+0000",
            "dateModified": "2018-03-12T23:03:01+0000",
            "about": [
                "Headphones",
                "PC gaming",
                "Arctis Pro",
                "Arctis Pro Wireless"
            ],
            "image": {
                "@type": "ImageObject",
                "url": "https://images.cdn.stuff.tv/sites/stuff.tv/files/brands/Steelseries/steelseries_arctis_pro_hs.png",
                "width": "770",
                "height": "578"
            },
            "mainEntityOfPage": "https://www.stuff.tv/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro"
        },
        {
            "@type": "NewsMediaOrganization",
            "name": "Haymarket media group",
            "url": "http://www.haymarket.com/",
            "sameAs": [
                "https://twitter.com/haymarket_media",
                "https://www.linkedin.com/company/haymarket-media-group",
                "https://www.instagram.com/haymarket.media/"
            ],
            "address": {
                "@type": "PostalAddress",
                "streetAddress": [
                    "Bridge House",
                    "69 London Road"
                ],
                "addressLocality": "Twickenham",
                "addressRegion": "London",
                "postalCode": "TW1 3SP",
                "addressCountry": "GB"
            },
            "publishingPrinciples": "http://complaints.haymarket.com/",
            "logo": "https://images.cdn.stuff.tv/sites/stuff.tv/files/copyright_0.png",
            "foundingDate": "1965-07-01",
            "ethicsPolicy": "http://complaints.haymarket.com/",
            "diversityPolicy": "http://complaints.haymarket.com/",
            "correctionsPolicy": "http://complaints.haymarket.com/",
            "ownershipFundingInfo": "http://complaints.haymarket.com/",
            "masthead": "https://cdn.stuff.tv/about-us",
            "missionCoveragePrioritiesPolicy": "http://complaints.haymarket.com/",
            "verificationFactCheckingPolicy": "http://complaints.haymarket.com/",
            "unnamedSourcesPolicy": "http://complaints.haymarket.com/",
            "actionableFeedbackPolicy": "http://complaints.haymarket.com/",
            "contactPoint": [
                {
                    "@type": "ContactPoint",
                    "contactType": "Newsroom contact",
                    "email": "stuff@haymarket.com",
                    "telephone": "+44 (0) 208 267 5036",
                    "url": "https://cdn.stuff.tv/contact-us"
                }
            ]
        },
        {
            "@type": "WebSite",
            "name": "Stuff",
            "url": "https://www.stuff.tv/",
            "sameAs": [
                "https://www.facebook.com/joinstuff",
                "https://twitter.com/Stufftv",
                "https://plus.google.com/+StuffTV",
                "https://www.youtube.com/user/stuffmagazine"
            ]
        }
    ]
}</script>
<link href="https://www.stuff.tv/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro?_format=amp" rel="amphtml" />
<meta name="description" content="Uprated speakers and a dedicated DAC make this the headset for serious sound fans" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.stuff.tv/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" />
<link rel="shortlink" href="https://www.stuff.tv/node/100000510" />
<meta property="og:site_name" content="Stuff" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.stuff.tv/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" />
<meta property="og:title" content="Gaming headphones go Hi-Res with the Steelseries Arctis Pro" />
<meta property="og:description" content="Uprated speakers and a dedicated DAC make this the headset for serious sound fans" />
<meta property="og:image" content="https://images.cdn.stuff.tv/sites/stuff.tv/files/brands/Steelseries/steelseries_arctis_pro_hs.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@stufftv" />
<meta name="twitter:url" content="https://www.stuff.tv/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" />
<meta name="twitter:description" content="Uprated speakers and a dedicated DAC make this the headset for serious sound fans" />
<meta name="twitter:title" content="Gaming headphones go Hi-Res with the Steelseries Arctis Pro" />
<meta name="twitter:image" content="https://images.cdn.stuff.tv/sites/stuff.tv/files/brands/Steelseries/steelseries_arctis_pro_hs.png" />
<meta name="apple-itunes-app" content="app-id=506367508" />
  <title>Gaming headphones go Hi-Res with the Steelseries Arctis Pro | Stuff</title>
      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://css.cdn.stuff.tv/sites/stuff.tv/files/advagg_css/css__YZMmyCjxADNsxWJVyzxskiYBiPsGboww8DDJoAv1iVA__PqGVjSeXe3e-YM4xspxCavDlyydtEB28TRpZPTEwV5I__4QaYPIGe_0qg8hbREAG8hesoCoxLHP_WeXHjN79B0Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://css.cdn.stuff.tv/sites/stuff.tv/files/advagg_css/css__BF8W_blKQtPnbjQTY9x1jeMYAPMgw_DaHD_Jx-1OrhE__VgwyfQt-yRZrTCQFX_pOadE6PR9mZKmik_FgvfGFGJc__4QaYPIGe_0qg8hbREAG8hesoCoxLHP_WeXHjN79B0Hc.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://css.cdn.stuff.tv/sites/stuff.tv/files/advagg_css/css__jjEdIwINPRs5BCpSK59_JjLiKBCs__QLmL3t8MvHU1k__3PWeSxBEp25JZfdB0q4a1THV5KGElJ3sZQngWGz2xDM__4QaYPIGe_0qg8hbREAG8hesoCoxLHP_WeXHjN79B0Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://css.cdn.stuff.tv/sites/stuff.tv/files/advagg_css/css__Xc89eL2gigIjhDYMGETn7FkcWiTHtRS0I6QpQbyYH4o__FP_JjkXIR7SwDKSFxbytsonvqq498S1pXxNjboh689o__4QaYPIGe_0qg8hbREAG8hesoCoxLHP_WeXHjN79B0Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://css.cdn.stuff.tv/sites/stuff.tv/files/advagg_css/css__F4DGzaQ3JMSywZYTdHQqhVqJ_IKuCHvsD2vZtn-vC8I__mw3G8NGXabG0e3sRuhZY09x1g7fj37wx1Yqf-lSEJg0__4QaYPIGe_0qg8hbREAG8hesoCoxLHP_WeXHjN79B0Hc.css" media="all" />
<style>#sliding-popup.sliding-popup-top{background:#5c5c5c;}#sliding-popup .popup-content #popup-text h2,#sliding-popup .popup-content #popup-text p{color:#ffffff !important;}
</style>
<link type="text/css" rel="stylesheet" href="https://css.cdn.stuff.tv/sites/stuff.tv/files/advagg_css/css__ShNx7CFjFIkZKZf947hX0stVlMm8h7lXOa4R6bbB-_E__1nwg8USdEFd_l8P3PtXt7NkwCZEACCzNqJpnjEykE0U__4QaYPIGe_0qg8hbREAG8hesoCoxLHP_WeXHjN79B0Hc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://css.cdn.stuff.tv/sites/stuff.tv/files/advagg_css/css__8F8x2OjiCexgY1_HbJzTQmSDsmOv3lwEv0PHuBcKYh0__kLjXnjgzprLwlc9o6pU0AJH2LtcXYV61gZX02fVTj_I__4QaYPIGe_0qg8hbREAG8hesoCoxLHP_WeXHjN79B0Hc.css" media="all" />

      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-100000510 node-type-article i18n-en section-hot-stuff hot-stuff byline-available" >
    <div class="region region-page-top">
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TVRZ8SQ" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>  </div>
   
<div id="page">

  <header id="header" role="banner" class="clearfix">
    <div class="grey">
      <div class="container">
        <div class="grid_16">
            <div class="region region-hat">
    <div id="block-lang-dropdown-language" class="block block-lang-dropdown first odd">

        <h2 class="block__title block-title">Languages</h2>
    
  <form action="/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" method="post" id="lang-dropdown-form" accept-charset="UTF-8"><div><div class="form-item form-type-select form-item-lang-dropdown-select">
 <select style="width:140px" class="lang-dropdown-select-element form-select" id="edit-lang-dropdown-select" name="lang_dropdown_select"><option value="en" selected="selected">&lt;span&gt;Stuff UK&lt;/span&gt;
</option><option value="fr-FR">&lt;span&gt;Stuff France&lt;/span&gt;
</option><option value="en-IN">&lt;span&gt;Stuff India&lt;/span&gt;
</option><option value="en-MY">&lt;span&gt;Stuff Malaysia&lt;/span&gt;
</option><option value="en-SG">&lt;span&gt;Stuff Singapore&lt;/span&gt;
</option><option value="eid-2">&lt;span class=&quot;i19ndropdownplus new-window&quot; data-url=&quot;http://www.stuffmideast.com/&quot;&gt;Stuff Middle East&lt;/span&gt;
</option><option value="eid-1">&lt;span class=&quot;i19ndropdownplus new-window&quot; data-url=&quot;http://www.stuff.co.za&quot;&gt;STUFF South Africa&lt;/span&gt;
</option></select>
</div>
<input type="hidden" name="lang_dropdown_type" value="language" />
<input type="hidden" name="en" value="/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" />
<input type="hidden" name="fr-FR" value="/fr" />
<input type="hidden" name="en-IN" value="/in" />
<input type="hidden" name="en-MY" value="/my" />
<input type="hidden" name="en-SG" value="/sg" />
<noscript><div>
<input type="submit" id="edit-submit" name="op" value="Go" class="form-submit" />
</div></noscript><input type="hidden" name="form_build_id" value="form-otlnxXSwFdO5wSM-Vv1ksbQMNbaOgNZ_DU2q15JdJYY" />
<input type="hidden" name="form_id" value="lang_dropdown_form" />
</div></form>
</div>
<div id="block-buy-magazine-buy-magazine-short" class="block block-buy-magazine even">

      
  <a href="https://www.themagazineshop.com/stu/wsbpp18/" class="themag" target="_blank">Subscribe to the magazine</a>
</div>
<div id="block-stuff-login-extras-stuff-login-extras-block" class="block block-stuff-login-extras odd">

      
  <div class="item-list"><ul class="ajax-register-links inline"><li class="first last"><a href="/ajax_register/login/nojs" class="ctools-use-modal ctools-modal-ctools-ajax-register-style" rel="nofollow" title="Login">Login</a></li>
</ul></div>
</div>
<div id="block-menu-menu-social-icons" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Follow us</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/joinstuff" title="Follow Stuff on Facebook" class="menu__link menu_icon menu-163">Stuff on Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/Stufftv" title="Follow Stuff on Twitter" class="menu__link menu_icon menu-164">Stuff on Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/+StuffTV" title="Follow Stuff on Google Plus" rel="publisher" class="menu__link menu_icon menu-165">Stuff on Google</a></li>
<li class="menu__item is-leaf last leaf"><a href="https://www.youtube.com/user/stuffmagazine" title="Subscribe to Stuff&#039;s YouTube channel" class="menu__link menu_icon menu-615">Stuff on YouTube</a></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>
    <div class="red">
      <div class="container">
        <div class="grid_16 top-header-grid clearfix">
                      <a href="/" class="logo-retina" title="Home" rel="home" id="logo_retina"><img src="/sites/stuff.tv/themes/stuff/logo_retina.png" alt="Home" /></a>
            <a href="/" class="logo-standard" title="Home" rel="home" id="logo"><img src="/sites/stuff.tv/themes/stuff/logo.png" alt="Home" /></a>
                    <div id="mobile-search-trigger"></div>
          <div id="mobile-menu-trigger">Menu</div>
        </div>
      </div>
    </div>
    <div class="over">
      <div class="container">
        <div class="grid_16">
            <div class="region region-header-top">
    <div id="block-search-form" class="block block-search first last odd" role="search">

      
  <form action="/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." class="auto_submit form-text form-autocomplete" placeholder="Enter your keywords here" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" /><input type="hidden" id="edit-search-block-form--2-autocomplete" value="https://www.stuff.tv/index.php?q=admin/search/autocomplete" disabled="disabled" class="autocomplete" />
</div>
<input type="hidden" name="form_build_id" value="form-TxHe90wtno8nocMfV5_Aj1hbopffsA1GBvTuDPmIWIo" />
<input type="hidden" name="form_id" value="search_block_form" />
<input type="hidden" name="typed" value="" />
<input type="hidden" name="pos" value="top" />
<input type="hidden" name="source" value="textfield" />
</div>
</div></form>
</div>
  </div>
                      <nav id="main-menu" role="navigation" class="clearfix">
              <ul class="menu"><li class="menu__item is-leaf first leaf hot-stuff-menu-link"><a href="/hot-stuff" class="menu__link">Hot Stuff</a></li>
<li class="menu__item is-leaf leaf news-menu-link"><a href="/news" class="menu__link block-menu">News</a></li>
<li class="menu__item is-leaf leaf reviews-menu-link"><a href="/reviews" class="menu__link block-menu">Reviews</a></li>
<li class="menu__item is-leaf leaf features-menu-link"><a href="/features" class="menu__link">Features</a></li>
<li class="menu__item is-leaf leaf top-10s-menu-link"><a href="/top-10" class="menu__link no-transform">TOP 10s</a></li>
<li class="menu__item is-leaf leaf deals-menu-link"><a href="/deals/best-stuff-deals" class="menu__link">Deals</a></li>
<li class="menu__item is-leaf leaf win-menu-link"><a href="/win" class="menu__link">WIN</a></li>
<li class="menu__item is-leaf leaf newsletter-menu-link"><a href="http://pages.haymarket.com/stuff/stuff-form.html" class="menu__link">Newsletter</a></li>
<li class="menu__item is-leaf last leaf feedback-menu-link"><a href="/" class="menu__link feedbackify-trigger">Feedback</a></li>
</ul>            </nav>
                    <div class="desktop-search"></div>
        </div>
      </div>
    </div>
    <div class="container">
      <div class="grid_16">
              </div>
    </div>
  </header>

  <div class="fake-body">
        <div id="trending" class="container hot-stuff"><div class="grid_16 trending hot-stuff">  <div class="region region-trending">
    <div id="block-views-taxonomies-block-1" class="block block-views first last odd">

      
  <div class="container">
  <div class="view view-taxonomies view-id-taxonomies view-display-id-block_1 view-dom-id-f5f0b573f7d67a3bde0900a4b4d2ad04">
                
    
          <div class="attachment attachment-before">
        <a href="#" class="hot-stuff-filter-toggle">Filter</a>
        <div class="view view-taxonomies view-id-taxonomies view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-sponsor-logo">        <div class="field-content"><a href="/hot-stuff"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source data-srcset="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/logo/public/HotStuffLogo.png?itok=IysTj1XG&amp;timestamp=1509795181 1.5x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/logo-small/public/HotStuffLogo.png?itok=zQ1AF_wS&amp;timestamp=1509795181 1x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/logo/public/HotStuffLogo.png?itok=IysTj1XG&amp;timestamp=1509795181 2x" data-aspectratio="395/50" />
<!--[if IE 9]></video><![endif]-->
<img  class="lazyload" data-aspectratio="" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="" title="" />
</picture></a></div>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>      </div>
    
          <div class="view-content">
          <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/apps">Apps</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/audio">Audio</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/cameras">Cameras</a></span>  </div>  </div>
  <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/cars-bikes">Cars &amp; bikes</a></span>  </div>  </div>
  <div class="views-row views-row-5 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/gaming">Gaming</a></span>  </div>  </div>
  <div class="views-row views-row-6 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/gear">Gear</a></span>  </div>  </div>
  <div class="views-row views-row-7 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/promoted">Promoted</a></span>  </div>  </div>
  <div class="views-row views-row-8 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/smart-home">Smart home</a></span>  </div>  </div>
  <div class="views-row views-row-9 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/smartphones">Smartphones</a></span>  </div>  </div>
  <div class="views-row views-row-10 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/tablets-computers">Tablets &amp; computers</a></span>  </div>  </div>
  <div class="views-row views-row-11 views-row-odd">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/tech-toys">Tech toys</a></span>  </div>  </div>
  <div class="views-row views-row-12 views-row-even">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/tvs">TVs</a></span>  </div>  </div>
  <div class="views-row views-row-13 views-row-odd views-row-last">
      
  <div class="views-field views-field-name-i18n">        <span class="field-content"><a href="/hot-stuff/wearables">Wearables</a></span>  </div>  </div>
      </div>
    
    
    
    
    
    
  </div></div>

</div>
  </div>
</div></div>        <div id="main" class="container clearfix"  >
                                                <div id="content" class="column grid_16 clearfix" role="main">

        
                <a cid="main-content"></a>
                        
                                                <div id="content-top">
                  </div>
        




<article class="node-100000510 node node-article view-mode-hot_stuff_content clearfix hot-stuff-content">
    <header>
              <div class="main-image">
          <div class="field field-name-field-image field-type-image field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=d67rZYqO&amp;timestamp=1520599201 1.5x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=txit7AYe&amp;timestamp=1520599201 1x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=d67rZYqO&amp;timestamp=1520599201 2x" media="only screen and (max-width : 480px)" />
<source srcset="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=_ufDrNya&amp;timestamp=1520599201 1.5x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=5Tz6O6H0&amp;timestamp=1520599201 1x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=_ufDrNya&amp;timestamp=1520599201 2x" media="only screen and (max-width : 767px)" />
<source srcset="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=d67rZYqO&amp;timestamp=1520599201 1.5x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=txit7AYe&amp;timestamp=1520599201 1x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-mobile-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=d67rZYqO&amp;timestamp=1520599201 2x" media="only screen and (max-width : 1023px)" />
<source srcset="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=_ufDrNya&amp;timestamp=1520599201 1.5x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=5Tz6O6H0&amp;timestamp=1520599201 1x, https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=_ufDrNya&amp;timestamp=1520599201 2x" />
<!--[if IE 9]></video><![endif]-->
<img  src="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/main-full-width-retina/public/brands/Steelseries/steelseries_arctis_pro_hs.png?itok=_ufDrNya&amp;timestamp=1520599201" alt="" title="" />
</picture></div>
      </div>
</div>
        </div>
      
            

      <div class="trust-project-indicator--type-of-work">News</div>

                    <h1 class="node__title node-title">Gaming headphones go Hi-Res with the Steelseries Arctis Pro</h1>
      
            
        
                  <div class="standfirst"><div class="field field-name-field-standfirst field-type-text-long field-label-hidden">
    <div class="field-items">
          <div class="field-item even">Uprated speakers and a dedicated DAC make this the headset for serious sound fans</div>
      </div>
</div>
</div>
        
                        <div class="tags">
            <div class="category">
              <!-- <a href="<a href="/taxonomy/term/13822" class="label_category">Audio</a>"/><a href="/taxonomy/term/13822" class="label_category">Audio</a></a> -->
              <a href="/taxonomy/term/13822" class="label_category">Audio</a>            </div>
                          <div class="sub-category">
                       </div>
        </div>
        
                  <div class="authorship clearfix">
            <!-- Hiding time from page 2 onwards. -->

                          <div class="field field-name-field-byline field-type-entityreference field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><div class="article-byline">
      <div class="field field-name-field-image field-type-image field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><a href="/team/tom-morgan"><img src="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/thumbnail/public/tom_morgan_new_stuff_pic.jpg?itok=iyxyol7r" width="100" height="100" alt="" /></a></div>
      </div>
</div>
    <div class="byline-content">
    <div class="author">
    	<span>by&nbsp;</span><a itemprop="author" itemscope itemtype="http://schema.org/Person" rel="author" href="/team/tom-morgan"><span itemprop="name"> Tom Morgan</span></a>
    </div>
    <div class="follow-button">
      <div class="field field-name-field-twitter field-type-text field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><a href="https://twitter.com/tommorgan3" class="twitter-follow-button" data-show-count="false" data-lang="en">Follow @tommorgan3</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.async=true,js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
      </div>
</div>
    </div>
  </div>
</div>
</div>
      </div>
</div>
                                      <div class="separator">|</div>
              <div class="ago">
  <i class="fa fa-clock-o" aria-hidden="true"></i>
  1 hour ago</div>
                      </div>
                  </header>
  
  <div class="amp-content">
    <div class="trust-notification">
  <span class="trust-notification--trust-mark">We are part of The Trust Project</span>
  <a href="/about-trust-project" class="trust-notification--link">What is it?</a></div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden">
    <div class="field-items">
          <div class="field-item even"><div><p>Steelseries is serious about giving your gaming audio a sonic step up: its new Arctis Pro headset comes with its own dedicated DAC, which is Hi-Res certified for 24-bit/96kHz streaming straight from your PC or PS4. The cans themselves have drivers capable of 40,000Hz frequencies, which is twice as sensitive as your typical gaming gear.</p>
<p>High quality materials match hi-res audio, with a mix of aluminium, steel and soft-touch rubber adding a touch of class. All the other Steelseries headset staples are on board, too, including the ski goggle-style headband, retractable microphone and subtle LED lighting on the ear cups.</p>
<p>If you want to cut the cord, there's also a wireless version with its own breakout box, complete with OLED screen for changing settings and a charging slot for hot-swapping the headset battery when you're running low. Cans connect to base unit over a lossless 2.4G signal, but there's Bluetooth for pairing to a smartphone as well.</p>
<p>Both are available right now, with the Arctis Pro + GameDAC setting you back £249.99. The Arctis Pro Wireless is a slightly more costly £299.99.</p></div></div>
      </div>
</div>
<div class="field field-name-field-label field-type-taxonomy-term-reference field-label-hidden">
    <div class="field-items">
          <div class="field-item even">Audio</div>
      </div>
</div>
  </div>
</article>


<div id="newsletter-prompt" class="bottom-right hidden">
  <div class="prompt-container">
  	<h2 class="prompt-title">Stay on top of tech with Stuff in your inbox every week</h2>
  	<span class="prompt-close"></span>
  	<div class="prompt-form">
  		<form action="/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" method="post" id="newsletter-prompt-signup-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-email">
 <input type="text" id="edit-email" name="email" value="" size="60" maxlength="128" class="form-text" />
</div>
<div id="newsletter-prompt-signup"></div><input type="submit" id="newsletter-prompt-submit" name="op" value="Sign Up" class="form-submit" /><input type="hidden" name="form_build_id" value="stuff::en::newsletter_prompt_signup_form::2018031300" />
<input type="hidden" name="form_id" value="newsletter_prompt_signup_form" />
</div></form>  	</div>
  	<h2 class="prompt-thankyou hidden">Thank you for registering for our Newsletter</h2>
  	<h3 class="prompt-description hidden">We will send you relevant emails and updates.</h3>
  </div>
</div>
          <div class="region region-content-bottom">
    <div id="block-radiumone-radium-one-7" class="block block-radiumone first last odd">

      
  <div class="buttons-container">
		<div class="button"></div>
    <div class="text">Share</div>
</div>
<div class="popup-overlay clearfix">
  <span class="closebtn"></span>
  <div class="icon"></div>
  <div class="pw-share-text">Share</div>
  <div  class="pw-widget pw-counter-horizontal" pw:layout="popup" pw:twitter-via="StuffTV" pw:url="https://www.stuff.tv/hot-stuff/audio/gaming-headphones-go-hi-res-steelseries-arctis-pro" pw-share-popups>
    <a class="pw-button-facebook pw-look-native" data="facebook"></a><a class="pw-button-twitter pw-look-native" data="twitter"></a><a class="pw-button-googleplus pw-look-native" data="googleplus"></a><a class="pw-button-email pw-look-native" data="email"></a><a class="pw-button-whatsapp pw-look-native" data="whatsapp"></a>  </div>
</div>

</div>
  </div>
      </div><!-- /#content -->

      
    </div><!-- /#main -->
  </div>

  <div class="container">
    <div class="grid_16">
          </div>
  </div>

        <div id="footer-links">
      <div class="container">
        <div class="grid_16">
            <div class="region region-footer-links-left">
    <div id="block-stuff-login-extras-stuff-login-extras-block--2" class="block block-stuff-login-extras first odd">

      
  <div class="item-list"><ul class="ajax-register-links inline"><li class="first last"><a href="/ajax_register/login/nojs" class="ctools-use-modal ctools-modal-ctools-ajax-register-style" rel="nofollow" title="Login">Login</a></li>
</ul></div>
</div>
<div id="block-menu-menu-footer-left-links" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer - Left links</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/about-us" class="menu__link">About Stuff  /</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact-us" class="menu__link">/  Contact  /</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.haymarket.com/TermsAndConditions.aspx" class="menu__link">/  Legal</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.haymarket.com/PrivacyPolicy.aspx" target="_blank" class="menu__link">Privacy Policy  /</a></li>
<li class="menu__item is-leaf leaf"><a href="/advertise" class="menu__link">/ Advertise</a></li>
<li class="menu__item is-leaf leaf"><a href="/sponsored-and-promoted-content" class="menu__link">Sponsored/Promoted Content</a></li>
<li class="menu__item is-leaf leaf"><a href="http://www.haymarket.com/CookiePolicy.aspx" target="_blank" class="menu__link">Cookie Policy /</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://complaints.haymarket.com" target="_blank" class="menu__link">/ Editorial Complaint?</a></li>
</ul>
</div>
  </div>
            <div class="region region-footer-links">
    <div id="block-menu-menu-social-icons-bottom" class="block block-menu first odd" role="navigation">

        <h2 class="block__title block-title">Follow us</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://www.facebook.com/joinstuff" class="menu__link menu_icon menu-1630" target="_blank">Facebook</a></li>
<li class="menu__item is-leaf leaf"><a href="https://twitter.com/Stufftv" class="menu__link menu_icon menu-1631" target="_blank">Twitter</a></li>
<li class="menu__item is-leaf leaf"><a href="https://plus.google.com/+StuffTV" rel="publisher" class="menu__link menu_icon menu-1632" target="_blank">G Plus</a></li>
<li class="menu__item is-leaf leaf"><a href="https://www.youtube.com/user/stuffmagazine" class="menu__link menu_icon menu-1633" target="_blank">YouTube</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://pages.haymarket.com/stuff/stuff-form.html?_ga=1.215981076.243855249.1422451570" class="menu__link">Newsletter</a></li>
</ul>
</div>
<div id="block-buy-magazine-buy-magazine" class="block block-buy-magazine last even">

        <h2 class="block__title block-title">Subscribe to the magazine</h2>
    
    <div id="buy_magazine_print" class="clearfix">
    <div class="main_image small-4 columns">
        <a href="https://www.themagazineshop.com/stu/wsbpp18/"><img src="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/buy_magazine_print/public/03_mar_parent.jpg?itok=qAmsVI7c" width="360" height="480" alt="" /></a>    </div>
    <div class="content small-8 columns">
        <a href="https://www.themagazineshop.com/stu/wsbpp18/" class="arrow">Subscribe now</a>                  </div>
  </div>
  <div id="buy_magazine_digital" class="clearfix">
    <div class="main_image">
      <a href="https://www.themagazineshop.com/stu/wsbpp18/"><img src="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/buy_magazine_iphone/public/03_mar_parent.jpg?itok=iP5o8fTr" width="41" height="87" alt="" /></a>      <a href="https://www.themagazineshop.com/stu/wsbpp18/"><img src="https://images.cdn.stuff.tv/sites/stuff.tv/files/styles/buy_magazine_ipad/public/03_mar_parent.jpg?itok=ceH0CG3Z" width="123" height="160" alt="" /></a>    </div>
    <div class="content small-8 columns">
                      </div>
  </div>

</div>
  </div>
        </div>
      </div>
    </div>
        <div id="footer-wrapper">
      <div class="container">
        <div class="grid_16">
            <footer id="footer" class="region region-footer">
    <div id="block-copyright-notice-copyright-notice" class="block block-copyright-notice first last odd">

      
  <a href="http://www.haymarket.com/"><img src="https://images.cdn.stuff.tv/sites/stuff.tv/files/copyright_0.png" width="81px" height="20px" alt="" /></a><div class="copyright-notice-text">&copy; 2018 Haymarket Media Group</div>
</div>
  </footer>
        </div>
      </div>
    </div>
  </div><!-- /#page -->

  <script src="https://cdn.stuff.tv/sites/stuff.tv/files/google_tag/language/google_tag.en.script.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/libraries/modernizr/modernizr-latest.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js?v=1.7.2"></script>
<script src="https://cdn.stuff.tv/misc/jquery.once.js?v=1.2"></script>
<script src="https://cdn.stuff.tv/misc/drupal.js?p5i5h1"></script>
<script>
      Drupal.hcmExternalBlocks = {}; 
      Drupal.hcmExternalBlocks.availableSlots = [];</script>
<script>var ppos = "stuff nodes"; var pageDnaObj = {"content":{"authors":"","has_video":"false","has_gallery":"false","has_poll":"","id":"100000510","language":"en","page_of":"","rating_max":"5","rating_score":"","title":"GamingheadphonesgoHiReswiththeSteelseriesArctisPro","type":"Audio","landing":"","subtype":"","publish_date":"20180312","update_date":"20180312","publish_time":"2301","update_time":"2303","taxonomy_group1":"","taxonomy_group2":"","taxonomy_group3":"","taxonomy_group4":"","freetags":"","word_count":"180","pagetype":""},"navigation":{"locale":"enGB","site_domain":"www.stuff.tv","site_name":"stuff.uk","section_child1":"stuff.uk","section_child2":"HotStuff","section_child3":"Audio","section_child4":"none","section_child5":"Steelseries"},"search":{"searchphrase":""},"product":{"id":"","manufacturer":["Steelseries"],"model":["ArctisPro"],"category":["Gaminghardware","Audio"],"sub_category1":["PCgaming","Headphones"],"product_edition":"","style":"","size":"","condition":"","price":"","price_band":"","target_price":"","price_currency":"","offer_price":"","min_price":"","max_price":"","version":"","colour":"","dealer":"","dealer_id":"","dealer_group":"","features":"","location":"","green_band":""},"electronics":[],"adzone":{"2":"HotStuff","3":"Audio","4":"none","5":"Steelseries"}}</script>
<script async="async" src="https://cdn.stuff.tv/sites/all/modules/contrib/picture/lazysizes/lazysizes.min.js?v=1.0.1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.core.min.js?v=1.10.2"></script>
<script async="async" src="https://cdn.stuff.tv/sites/all/modules/contrib/picture/lazysizes/plugins/aspectratio/ls.aspectratio.min.js?v=1.0.1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/jquery_update/replace/misc/jquery.form.min.js?v=2.69"></script>
<script src="https://cdn.stuff.tv/misc/ajax.js?v=7.57"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/jquery_update/js/jquery_update.js?v=0.0.1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/modules/custom/hcm_apachesolr/js/hcm_apachesolr.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/modules/custom/hcm_apachesolr/js/hcm_apachesolr_search_autosubmit.js?p5i5h1"></script>
<script async="async" src="https://js-sec.indexww.com/ht/p/185499-201610479662419.js"></script>
<script src="https://c.amazon-adsystem.com/aax2/amzn_ads.js"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/gpt_ads/js/gpt_custom.stuff.js?p5i5h1"></script>
<script>document.createElement( "picture" );</script>
<script async="async" src="https://sadmin.brightcove.com/js/BrightcoveExperiences.js"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/hcm_external_blocks/js/skin.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/hcm_external_blocks/js/stickify_me.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/quote/quote.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/stickynav/js/stickynav.js?p5i5h1"></script>
<script src="https://tags.tiqcdn.com/utag/haymarket/stuff-d7/prod/utag.sync.js"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/ctools/js/ajax-responder.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/lang_dropdown/msdropdown/jquery.dd.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/misc/progress.js?v=7.57"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/ctools/js/modal.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/ajax_register/js/ajax-register.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/lang_dropdown/lang_dropdown.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/i19n/i19ndropdown/i19ndropdownplus/js/i19ndropdownplus.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/misc/autocomplete.js?v=7.57"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/modules/custom/hcm_apachesolr/js/hcm_apachesolr_track.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/themes/stuff/js/hot-stuff-filter.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/newsletter_prompt/js/newsletter_prompt.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/retsol/i19nretsol/js/i19nretsol.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/locale_redirector/js/prompt.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/moremenu/js/moremenu.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/sllogger/js/sllogger.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/libraries/blockadblock/blockadblock.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/custom/radiumone/js/radiumone.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/modules/features/site_sitewide/js/ckeditor_fix.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/themes/stuff/js/script.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/themes/stuff/js/menu.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/themes/stuff/js/feedbackify.js?p5i5h1"></script>
<script src="https://cdn.stuff.tv/sites/stuff.tv/themes/stuff/js/search-trigger.js?p5i5h1"></script>
<script>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</script>
  <script async="async" src="https://cdn.stuff.tv/sites/all/modules/contrib/picture/picturefill2/picturefill.min.js?v=2.3.1"></script>
<script async="async" src="https://cdn.stuff.tv/sites/all/modules/contrib/picture/picture.min.js?v=7.57"></script>
<script async="async" src="https://tags.tiqcdn.com/utag/haymarket/stuff-d7/prod/utag.js"></script>
<script src="https://cdn.stuff.tv/sites/all/modules/contrib/eu_cookie_compliance/js/eu_cookie_compliance.js?p5i5h1"></script>
<script>var fby = fby || []
fby.push(['showTab', {id: '8344', position: 'right', color: '#F40028'}]);
(function () {
  var f = document.createElement('script'); f.type = 'text/javascript'; f.async = true;
  f.src = '//cdn.feedbackify.com/f.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(f, s);
})();</script>
<script>var skimlinks_domain = "go.redirectingat.com";</script>
<script async="async" src="https://s.skimresources.com/js/1044x507144.skimlinks.js"></script>
</body>
</html>
